
Five Minute Rapid Start Guide 

A task is something you have to do, such as write a letter, or wash the car. You can predict and manage your 
workload effectively, and give yourself focus, by creating a list of all your tasks in Outlook® and then automatically 
scheduling them using Taskline. 

To schedule your tasks for the first time: 

1. In Outlook, open your Tasks folder.  

2. Enter how long you think each task will take. To do this, first open an existing task in Outlook, for example by 
double clicking it, or create a new task by clicking File → New → Task.  

3. On the Taskline tab of the task form, enter how long you think the task will take in the Total Work box, 
which is set to 0 by default. If you don't yet have a Taskline tab, use the Details tab. You can enter the 
Total Work as a number of minutes, hours, days or weeks; the abbreviations are m, h, d and w. For example, 
to set Total Work to 3 hours, you can type "3h" or "3 hours". When you have updated Total Work, click 
Save and Close. 
 

4. Once you have assigned each task some Total Work, start Taskline by clicking the Taskline button  on the 
Outlook toolbar. Click OK on the Taskline dialog to accept the default options and schedule your tasks.  

5. When Taskline has finished, double-click a task to display the Taskline tab. Notice that Taskline has 
calculated Scheduled Start and Scheduled End dates and times for each task. The Scheduled Start is the 
recommended or most likely start date. The Scheduled End is the calculated completion date. More about 
these dates.  

6. Depending on which options you selected during Taskline Setup, Taskline might also place task entries in 
Outlook's calendar. These are entries in the calendar that represent your tasks. Task entries make it very 
easy to see what you are scheduled to do on any given day. Open your Outlook calendar and take a look! If 
you don't see task entries in your calendar and you would like them: 

1. Start Taskline by clicking the Taskline button  on the Outlook toolbar.  

2. Click the Calendar tab  

3. Select the Create for tasks that are Not Started or In Progress check box  

4. Click OK to have Taskline reschedule your tasks  

More on calendar task entries.  

7. You will probably want your tasks to be carried out in a certain order. One way of setting this order is to give 
each task a Priority (A1) value. Open each task that you want to schedule and give it a Priority (A1) 
value, which is set on the Taskline tab of the task form in Outlook. For example, give the first task that you 
want to do a Priority (A1) value of B10, the second task B20, and so on. Now start Taskline again. On the 
Tasks tab of the Taskline dialog, set Order by to Priority (A1), then click OK. Your tasks will now be 
rescheduled in the order you have set.  

Scheduling tasks using Natural Order is another popular method of setting the task order. Tasks in Outlook 
have a natural order, which is the order Outlook displays them in when sorting and grouping is turned off. The 
benefit of using natural order is that task ordering can be changed simply by dragging tasks, or groups of 
tasks, up and down the task list. This method can often be quicker than changing priority values.  

Notice that you use two main workflows in Taskline: 

1. The Taskline application – Start Taskline by clicking the Taskline button  in Outlook, or by using the 
Windows® Start menu. Taskline displays the options that control how it runs. Clicking OK will then schedule 
your tasks.  

2. The Taskline task form – If you want to set options for scheduling an individual task with Taskline, such as 
      

  

   
 
 
     
   
     

  

  
 
  

  
    

     

       

     

    
        

             

  
  
    
    

  
            

     

     

  If you are using Outlook 2007, click the middle icon in the Show group on the ribbon 
to display the Taskline tab.

Page 1 of 154



  

 
   
  

  

     

  
        

       
     
  
     
   
 

      
    

       
       
    
   

  
 
 
 

     

     

     

     

   

  
     
    
   
      
  

   
 
 
  

  

       
     
  

     
Total Work, you open the task in Outlook and set options on the Taskline tab of the form.  

Some time management advice: 

n You must leave some free time in your schedule, to allow for unforeseen items, or small items such as phone 
calls which cannot be scheduled individually but nevertheless collectively consume time. Scheduling yourself 
for every minute of your work day is not viable and you will inevitably fall behind schedule if you do this. You 
can build slack time into your schedule by setting the I start work at and/or the I stop work at times 
conservatively, or by adding a day time break specifically for slack time. All these settings are on the 
Working Week tab of Taskline's dialog. Another useful method is to overestimating task Total Work times.  

Some other things you can do are: 

n Move the Taskline toolbar so that it takes up less screen space. If your display is wide enough, you can drag 
the small vertical bar to the left of the Taskline toolbar and move it to the end of the standard Outlook 
toolbar.  

n If you have a simple list of tasks created using a text editor, word processor or similar, you can have Taskline 
convert this list into Outlook tasks. How?  

n Read or work through the Taskline tutorial.  

n Use Natural Order to set the order in which tasks are scheduled. How?  

n Tell Taskline when you wish to start working on your task list. How?  

n Force a task to start or finish on, before or after a certain date. You do this by placing a constraint on a 
task. More. Note that setting a task's Start or Due date has no effect on the way Taskline schedules tasks.  

n Have Taskline update the task Start and Due dates, as well as Scheduled Start and Scheduled End. How?  

n Tell Taskline what days you work, and what hours you work on those days, so that Taskline can accurately 
schedule your work. If you are using Taskline Professional Edition, you enter this information on the Working 
Hours tab of the Taskline dialog box. If you are using Taskline Standard Edition, you use the Working Week 
tab. How?  

n Update the tasks table view in Outlook to show task information particularly relevant to Taskline tasks, such 
as the Scheduled Start and Schedule End dates, Priority (A1) and Total Work. How?  

n Read some useful tips and guidelines on Planning Your Work effectively.  

n Find out how Taskline can help you.  
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What Taskline Can Do For You 

A task is something you have to do, such as fill in your expenses claim, or wash the car. Many people write down all 
their tasks on a piece of paper, to create a to-do list. Outlook's task list is a computerized version of this paper to-
do list. The standard Outlook task list allows you to create tasks, display them in a list and delegate them to 
others. However, Outlook cannot automatically schedule tasks, so you do not know when anything will get 
completed, or should be started. You do not know if deadlines can be met. This is where Taskline can help. 

If you place appointments in the Outlook calendar, Taskline can put the tasks there too, so that you have one view 
that completely details everything you have to do. Taskline will keep the calendar automatically updated as things 
change. 

Taskline accomplishes a similar job to expensive project management applications; it offers much of the power of 
the critical path analysis, but without the complexity. Taskline gives you answers to fundamental time-planning 
questions, such as: 

1. When should I start each task, and when can I expect to finish?  

2. When will I finish my current to-do list?  

3. Are all my current deadlines actually achievable?  

With Taskline, you can also quickly re-schedule your tasks, in response to changing priorities or new commitments. 
Unfinished tasks are automatically carried forward. Is it possible to complete that new assignment by the required 
deadline, given all your existing commitments? Taskline can tell you. 

Taskline organizes your schedule in the following ways: 

n Assigns each task a recommended, or most likely, start and end date and time. This process is called Task 
Scheduling. Such scheduling takes into account: 

n Preferred task order.  

n Your normal working week, and breaks during the day, such as lunch breaks.  

n The other commitments in your calendar, such as meetings and holidays.  

n Traveling time to and from meetings and other appointments.  

n External influences on tasks, such as deadlines.  

n Tells you when you can expect to finish your task list, or parts of it.  

n Tells you how new work will affect your existing commitments.  

n Tells you whether deadlines are achievable.  

n Carries forward unfinished tasks, rescheduling them for a future date.  

n Gives you the expected dates of milestones, or goals, which are significant events in your task list, such as 
finishing a package of work.  

n Issues enhanced reminders when or before tasks are due to start.  

n Tracks tasks that are complete or in progress.  

n Keeps a record of your completed work, either in the calendar or in a separate tasks folder.  

n Visually distinguishes certain categories of Tasks on the Outlook Calendar so that you can glance at the 
Calendar and see the status, or categories, of tasks, such as all tasks not yet started. This option is available 
for Outlook 2002 and newer.  

n Allows you to assign each task to a project, to help you organize your tasks more effectively.  

To learn the capabilities of Taskline, read or work through the Taskline tutorial.  
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Taskline Tutorial 

As well as reviewing this tutorial, you may also wish to view the 5 minute Taskline movie on our web site. 

This tutorial will bring you quickly up to speed with Taskline. The first 4 activities, which cover Taskline basics, take 
approximately 20 minutes to complete. The remaining activities will take a further 25 minutes. Completing these will 
enable you to get the most out of Taskline. 

The tutorial describes basic activities in Taskline that you might want to accomplish in the typical work week. The 
tutorial uses the example of a technical writer in a large corporation. However, all of the activities are familiar ones 
that you might encounter in most professional settings or your personal life.  

Important 

l This tutorial is designed for Taskline Professional Edition only. If you are using the evaluation version of 
Taskline, make sure you are using Professional edition. If necessary, select the Professional edition radio 
button on the Help / About tab of Taskline’s dialog, and then click Apply, to change Taskline versions.  

Note 

l While running through this tutorial, we recommend that you open this help file by clicking the Taskline 
Tutorial button on the Help / About tab of Taskline's dialog. Using this method will leave the help file open 
even when Taskline closes.  

In our tutorial, the first three activities describe how to begin using Taskline: 

n Entering the times that you work each week. You generally do this just once when you first start using 
Taskline.  

n Planning specific tasks, including the estimated time for each task.  

n Scheduling your work and showing your tasks in your Outlook calendar.  

You use two general workflows in Taskline: 

n If you want to enter general settings for your Outlook Calendar, your work week, and so forth, or you want to 
schedule your tasks, you click the Taskline button  on the toolbar in Outlook, on your Windows® Taskbar, 
or the Desktop.  

n If you want to set options for tracking an individual task with Taskline, such as a scheduling constraint or the 
task priority, you open the task and set options on the Taskline tab.  

Create New Folders for the Tutorial Tasks and Appointments 

For the purposes of this tutorial, we will create a new Outlook folder to contain the tutorial tasks and a second new 
folder for the tutorial appointments. This is to avoid existing tasks and appointments being intermingled with the 
items created during the tutorial. We will make these folders sub-folders of the existing Tasks and Calendar 
folders. 

To create the new tasks folder: 

1. If Outlook's Folder List isn't already displayed, have Outlook display it, by clicking on the View → Folder List 
menu option in Outlook 2002 and earlier. In Outlook 2003 and 2007, click View → Navigation Pane and then 
click the Folder List icon at the bottom of the Navigation Pane.  

2. On the Folder List, right click your Tasks folder and click New Folder on the pop up menu: 
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The Create New Folder dialog will be displayed.  

3. Type "Tutorial Tasks" in the Name box, which is the name of our new folder. Make sure that Folder contains 
shows Task Items and that the Tasks folder is selected in the Select where to place the folder list.  

4. Click OK to have Outlook create the new folder.  

To create the new calendar folder: 

1. On Outlook's Folder List, right click your Calendar folder and again click New Folder on the pop up menu.  

2. Type "Tutorial Cal" in the Name box. Make sure that Folder contains shows Calendar Items.  

3. Click OK to have Outlook create the new folder.  

Now we need to tell Taskline to use the folders we have just created: 

1. Click the Taskline button  in Outlook to start Taskline.  

2. On the Tasks tab of the Taskline dialog, click the Select button for the Schedule the tasks in option. This 
will display the Select Folder dialog.  

3. Select the Tutorial Tasks folder. You may need to click the + sign, to the left of the Tasks folder entry, to 
display the Tutorial Tasks folder. OK the Select Folder dialog.  

4. On the Calendar tab of the Taskline dialog, click the Select button for the My appointments are in option.  

5. Select the Tutorial Cal folder and click OK.  

6. Still on the Calendar tab, click the Select button for the Write task entries to option.  

7. Select the same Tutorial Cal folder and click OK.  

8. Back on the Taskline dialog, click the Apply button to save these changes.  

Important 

n When you click Apply, Taskline might give you some instructions regarding changing the default task form for 
the Tutorial folder. If so, you must follow these instructions before continuing this tutorial.  

We have now finished the initial tutorial housekeeping. 

Entering Your Working Hours 

Note 

l Times in this tutorial are shown using a 12 hour AM/PM format. If you are using a different time format, please 
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l  
convert to your local format when entering times.  

When using Taskline for the first time, you must tell Taskline the hours that you work. In our tutorial example, as a 
technical writer for a large corporation, your typical week runs from 9:00 AM until 5:00 PM, Monday through Friday, 
with a one-hour break starting at 12:00 PM. 

1. If Taskline is not already running, click the Taskline button  in Outlook.  

2. Click the Working Hours tab on Taskline's dialog, then enter the following information: 

n In the Working hours drop down list at the top of the dialog, make sure Default work week is 
selected. If it is not, select it now.  

n Taskline Professional Edition supports working different hours on different days of the week, but in our 
tutorial example we will work the same hours Monday through Friday. The Mon, Tue, Wed, Thu and Fri 
check boxes should already be selected. The Sat and Sun check boxes should not be selected. If this is 
not the case, make these selection changes now. The check boxes allow you to enter the time for all 
weekdays simultaneously, typing the information only once.  

n In the Mon row of the Start work column of edit boxes, enter "9 AM". You can omit this step if all five 
Mon to Fri boxes already show "9 AM".  

n In the box to the right, the Stop work column, enter "5 PM". You can omit this step if all five Mon to 
Fri boxes already show "5 PM".  

n In the next box, the From column, enter "12 PM". This is the time your lunch break starts.  

n In the next box, the To column, enter "1 PM". This is the time your lunch break ends.  

n Make sure that both Default hours and Schedule tasks which have been assigned these hours are 
selected.  

3. The Working Hours tab should now look like the following screen shot. Click Apply to save your settings and 
click Cancel to close the dialog box. 

 

How Many Hours Do You Work in a Day? 
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Some people work 10 hours a day, others much less. When we tell Taskline or Outlook that a task lasts for 1 day, or 
for 1 week, how many hours does that mean? So, for the final part of our initial setup, we must now tell Outlook 
how many working hours there are in a day and in a week: 

1. In Outlook, click Tools menu → Options → Other tab → Advanced Options button, to display the 
Advanced Options dialog.  

2. In Task working hours per day, enter 7. Note that this information excludes your lunch hour.  

3. In Task working hours per week, enter 35.  

4. Click OK on all the open Outlook dialogs.  

Entering Your Tasks 

The first stage in work scheduling is to break your work down into small chunks, or tasks. Each task should 
represent a specific part of your work. It should be short in duration &mdash; ideally just a few hours and certainly 
no more than a few days. 

In our tutorial example, the first step in your work week involves planning three projects that are due soon: 

n Chapter 2 of a user manual, which you think will take you 2 days and is your first priority.  

n Proof read a booklet, which will take you 3 hours and is your second priority.  

n Research documentation tools, which will take you 1 day and is your third priority.  

To create the first task, take the following steps: 

1. In Outlook, open the Tutorial Tasks folder you created earlier by clicking the Tutorial Tasks entry in the 
Folder List. If you cannot see the Tutorial Tasks entry, then click the + sign to the left of the Tasks folder 
on the Folder List. This will display sub-folders. Now click the Tutorial Tasks folder to open it.  

2. Click File menu → New → Task to create a new task. Or, simply double click on a blank area of the task list 
in Outlook.  

3. Enter the following information: 

n On the Task tab, enter "User Manual chapter 2" in the Subject box.  

n On the Taskline tab, in the Total Work box, enter "2d". This is shorthand for 2 days.  

n In the Priority (A1) box, enter "A10". With Priority (A1), you must enter a letter. The number is 
optional.  

4. Click Save & Close.  

You are now ready to create the second and third task. 

1. To create the second task, repeat the previous steps, 1-3, entering the following information: 

n On the Task tab, enter "Proof read Quick Start Guide" in the Subject box.  

n On the Taskline tab, in the Total Work box, enter "3h". This is shorthand for 3 hours.  

n In the Priority (A1) box, enter "A20".  

2. To create the third task, repeat the previous steps, 1-3, entering "Research documentation tools" in the 
Subject box, "1d" in the Total Work box, and "A30" in the Priority (A1) box. 

Tips 

n You can enter fractions in durations, for example "1.5 hours".  

n Setting task priorities with a letter and numeric value ending in zero, such as A10, A20, and so forth, 
allows you to insert other tasks in the future that may have priorities in between the priorities of your 
original list of tasks. In Taskline, you can also reprioritize your tasks quickly and easily by selecting the 
Options tab and then clicking the Renumber or Re-letter Priority (A1) button.  

n You are not restricted to using Priority (A1) to order your tasks. For example, you can tell Taskline to 
schedule your tasks in the order they are displayed in Outlook's task list instead, when all sorting and 
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grouping is turned off. This is called Natural Order. Displaying and scheduling tasks in Outlook's Natural 
Order is convenient, because tasks can be reprioritized by dragging them up and down the task list. 
However, this tutorial uses Priority (A1), as this is also a flexible method of prioritizing tasks.  

n Notice that when you have entered a value for Total Work, the Ignore this task check box is 
deselected. All new tasks are ignored by Taskline by default, but as soon as you add some Total Work, 
the Ignore this task check box will be automatically deselected. If you wish to have Taskline schedule 
a milestone, which is a task with zero Total Work, you will need to manually deselect the Ignore this 
task check box.  

n Taskline also works with the tasks you already have, before you installed the software. When Taskline 
runs, it converts standard Outlook tasks to Taskline tasks.  

To view your tasks, you can click the Tutorial Tasks folder in Outlook. Blue checks  appear next to the 
tasks that Taskline tracks.  

  

Now that you have planned your tasks, you can schedule them, as described in the next activity in the tutorial 
example. 

Scheduling Your Tasks 

Taskline makes planning your work quick and easy. Taskline schedules your work around existing appointments and 
also to fit in with your Working Hours. When you have scheduled your tasks with Taskline, you can also view them 
in the Outlook Calendar, like any other appointment.  

In our example, let's assume that today is a Saturday and you are planning your activities for next week. You want 
to run Taskline to schedule all three of your tasks for next week. 

1. In Outlook, click the Taskline button  to display the Taskline dialog.  

2. For the purposes of this tutorial, clear the Default to current date and time check box, which is on the 
Tasks tab. For real work however, it is common to leave this selected.  

3. In the First task starts at box, click the down arrow and select whatever date is the Monday just gone. 
Then, click on the First task starts at box and use the keyboard to change the time to 9 AM. Or, if today is 
Monday, select today's date, but again change the time to 9 AM. This date is the starting point for your 
schedule. It is not usual to plan in the past, but selecting the previous Monday is convenient for our tutorial, 
because Outlook initially opens the calendar on the current week.  

4. On the Order by list, select Priority (A1) and (if necessary) Ascending. This makes sure that Taskline 
schedules your tasks in the order of their Priority (A1) values. 

Your Tasks tab of the Taskline dialog should now look like the screen shot below. The First task starts at 
date only shows the day and time, because the actual date depends on whatever date you selected: 
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5. On the Calendar tab, select the Create for tasks that are Not Started or are In Progress check box, if 
necessary. This step tells Taskline to show your tasks in Outlook's calendar. It does this by creating "calendar 
task entries", which are appointments that represent your tasks. 

Tips 

n Task ordering, for example by using Priority (A1), is a simple system that is used in place of the 
complex logic links used by Project Management software.  

n You can change the priority later by editing the task.  

n If you are using a PDA, such as a Pocket PC, you may wish to manually prefix the Priority (A1) value 
to the start of the task subject, for example "A20 Proof read chapter 2", and then Order by Subject. 
This allows you to see and change Priority (A1) on the PDA, although you will not be able to use the 
Priority (A1) controls on the Taskline task form in Outlook if you use this method.  

6. Click OK to close the Taskline dialog box and schedule your tasks. You may see a message "The ‘First task 
starts at’ date is in the past. Is this what you intended?" Taskline warns you because starting your schedule 
in the past is unusual. However, we have chosen a start date of last Monday just the purposes of this 
tutorial, so select the Don’t tell me about this again check box and click Yes to continue. 
 
When Taskline has finished, the Summary of Task Schedule dialog box may appear. This contains useful 
information about your task list that we won't explore in this tutorial, so simply click OK to close this.  

Taskline will now have updated your task list and your calendar. To see the results of these steps, in Outlook, click 
the Tutorial Tasks folder and double-click a task. When you open your tasks in Outlook, you can see that dates 
have been set in the Scheduled Start and Schedule End boxes on the Taskline tab. These are the estimated or 
most likely start and end dates for your tasks. 

As few people can predict future work with 100% accuracy, for example a meeting may take longer than 
anticipated, you cannot usually start and finish every task exactly on schedule. However, the Scheduled Start and 
Scheduled End dates give you a very good idea of when you are likely to start working on a task, and when you 
are likely to finish it. 

You should have the same days and times as those shown below, but because your task dates depend on your 
chosen First task starts at date, dates have been removed from these screen shots: 
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Now open your Tutorial Cal folder to see your tasks in Outlook’s calendar. The calendar shows exactly the same 
date and time information as the tasks, it is just the view of that information that is different: 

 

"Calendar task entries" (the appointments that represent tasks) get deleted and recreated each time Taskline is 
run, so it is best not to change them, but rather change the task instead. 

You have finished the first three activities that describe how to start using Taskline: 

n Setting your work week.  

n Entering tasks.  

n Scheduling tasks.  

n Viewing your schedule in Outlook's calendar.  
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